Uploaded image for project: 'logback'
  1. logback
  2. LOGBACK-511

SyslogAppender quits after a while

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 0.9.13, 0.9.14, 0.9.15, 0.9.16, 0.9.17, 0.9.18, 0.9.19
    • Fix Version/s: 0.9.19
    • Component/s: logback-classic
    • Labels:
      None
    • Environment:

      At least Debian Etch with JDK5

      Description

      I have 5 applications servers and each one logs to one separate SysLog-Server. After Server-Restart, all is working fine.

      But after several days and weeks, more and more servers doesn't log to he SysLog-Server anymore. But I can't see an Syslog-Error in my Logs.
      I think this bug is related to http://jira.qos.ch/browse/LBCLASSIC-57.

      In my opinion, the most important fix would be to re-creae the SysLog-Appender if an exception/error occurs or to avaid that the SysLog-Appender dies.
      If I miss one single entry, than that's not nice. But if I miss all entries it's very serve.
      The SysLog-Appender is useless for me until this bug is fixed.

        Attachments

          Activity

            People

            • Assignee:
              logback-dev Logback dev list
              Reporter:
              res1st Ingo Siebert
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: